Jump to content
  • 0

Question

hi I just opened new register with xat but I can not go to chat rooms with my new register name it doesn't accept. my register name or password but I can go to forum could you help me please

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Make sure that you're entering the correct e-mail address/username or password.

 

Do you know the e-mail address that is associated to your xat account? If so, then try using your e-mail to login instead of your username.

 

If that doesn't work, then try resetting your account password here.

 

Please create a new topic if you're still unable to login after trying all the steps above.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hey,

 

Did you click on the link sent via email to confirm your registration?

 

Welcome on the forum ;) !

Share this post


Link to post
Share on other sites
  • 0

Welcome to the forum. If you're looking for some help, try opening a thread on the General Support Section.

Share this post


Link to post
Share on other sites
  • 0

The question or questions in this topic have been answered and an answer has been marked. This topic is now closed.

 

If you have any other questions, please open a new topic.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.