Jump to content

Recommended Posts

  • Game Makers

A simple issue(but still bored) is happening sometimes when I access the forum (I saw some other people talking about this).

 

I don't know if IPS or xat will fix it. 

 

"Maintenance in progress" is showing sometimes.

 

6977d23578264e2b94f63d5fa5972d7e.png

 

 

 

@Brandon or @Admin

Link to post
Share on other sites
  • Advanced Members
1 hour ago, Lamingtons said:

A simple issue(but still bored) is happening sometimes when I access the forum (I saw some other people talking about this).

 

I don't know if IPS or xat will fix it. 

 

"Maintenance in progress" is showing sometimes.

 

6977d23578264e2b94f63d5fa5972d7e.png

 

 

 

@Brandon or @Admin

i see that me too but when i do refresh its work fine now .

Link to post
Share on other sites
  • Game Makers
4 minutes ago, iMoHd said:

i see that me too but when i do refresh its work fine now .

Sometimes your browser save the cached version so you will need to clear it. This is happening for me, i need to login on "private tab" to work.

Link to post
Share on other sites
  • Volunteers
1 hour ago, Admin said:

can you get all the headers and pm  ?

 

Do you mean if you see the forum header when this happens? If so, no you don't, its just that white page with the maintenance message.

Link to post
Share on other sites
  • Game Makers
Quote

Failed to load resource: the server responded with a status of 503 (Service Unavailable)

 

I got that message on the Chrome's console; Couldn't do a capture of the headers. You should check the server logs and see what's wrong because I don't think, the headers will help you to fix the issues.

Link to post
Share on other sites
  • Advanced Members

https://forum.xat.com/

GET / HTTP/1.1
Host: forum.xat.com
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate, br
Cookie:
DNT: 1
Connection: keep-alive
Upgrade-Insecure-Requests: 1

HTTP/1.1 503 Service Unavailable
Date: Mon, 06 Mar 2017 12:44:07 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Server: cloudflare-nginx
CF-RAY: 33b567906ba50e4e-MXP
----------------------------------------------------------

Link to post
Share on other sites
  • Members

It seems to be a caching problem.  Maybe this is some configuration.

I found the "Must-revalidate" field in the response that might be considering the redirect page as the same page.

 

Error header:

 

HTTP/1.1 503 Service Unavailable
Date: Mon, 06 Mar 2017 13:32:13 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Server: cloudflare-nginx
CF-RAY: 33b5ae05c5854b81-GRU

4b6  --- Its the response body, 4b6 is seems a part of the CloudFlare cache code, I searched here and did not find any of my requests that had this cache.


Check: https://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.9.4
*. If the response includes the "must-revalidate" cache-control
          Directive, the cache MAY use that response in replying to
          Subsequent request. But if the response is stale, all caches
          MUST first revalidate it with the origin server, using the
          Request-headers from the new request to allow the origin server
          To authenticate the new request.

 

Try using only no-store and no-cache.

 

Also, POST requests are not being redirected to HTTPS, Only the links have been modified to https. Probably because of the IPS configuration.

 

I got it on the POST request:

 

HTTP/1.1 200 OK
Date: Mon, 06 Mar 2017 13:20:50 GMT
Content-Type: text/html;charset=UTF-8
Content-Length: 62484
Connection: keep-alive
Set-Cookie: __cfduid=----; expires=Tue, 06-Mar-18 13:20:49 GMT; path=/; domain=.xat.com; HttpOnly
Set-Cookie: ips4_IPSSessionFront=SOMESESSION; path=/; secure; HttpOnly
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
X-XSS-Protection: 0
Server: cloudflare-nginx
CF-RAY: 33b59d57153f4a96-GRU


I do not know if the problem is the Cloudflare, But you shall check it HERE .


Mega

  • Award 3
Link to post
Share on other sites
  • 2 weeks later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.