Jump to content
Admin

xat Mobile Bug Reporting

Recommended Posts

This topic is no longer being used for bug reporting.

 

Please visit the following page to create a bug report: https://forum.xat.com/bug-tracker/mobile-applications/.

 

You can see the xat mobile bug list here: https://docs.google.com/spreadsheets/d/1yxR82y9hJ-yABX_j0XNrYO6z76iGEMNzt-tQ8erKKJQ/edit?usp=sharing.

 

When reporting, remember to include:

  • Device OS information.
  • Software version number.
  • Model of phone.
  • Screen resolution.
  • Orientation of screen when bug occurs.
  • Your xat username and ID.
  • Like 1

Share this post


Link to post
Share on other sites

Reports for iOS 1.5.1:

  1. Text doesn't wrap and goes past message container (see image here). This was a private chat.
  2. My avatar is treated as a GIF when it's not a GIF.
  • Like 1

Share this post


Link to post
Share on other sites
12 minutes ago, Brandon said:

My avatar is treated as a GIF when it's not a GIF.

Can you give me more details about this one? 

  • No 1

Share this post


Link to post
Share on other sites
32 minutes ago, Brandon said:

Reports for iOS 1.5.1:

  1. Text doesn't wrap and goes past message container (see image here). This was a private chat.
  2. My avatar is treated as a GIF when it's not a GIF.

Happens with group descriptions too if they're long enough (noticed it for xat5). 

Share this post


Link to post
Share on other sites
39 minutes ago, Maverick said:

Can you give me more details about this one? 

I am using a regular image as my avatar. The application displays it in such a way that it goes from the left of the image to the right of the image, making it move rapidly back and forth as if it's trying to display a strip of images (like a GIF). Think about how xat regularly shows GIFs on xat: You upload a strip of images, the image is shown by going from the most left frame to the most right frame, and then back to the first frame. It appears to be doing that when I don't even have a strip uploaded. It's a single, one-frame image.

  • Cool 1

Share this post


Link to post
Share on other sites
4 minutes ago, FrozenZuke said:

Can I get the iOS TestFlight code or download beta link?

You need to be invited. If you didn't receive an invitation, you're going to have to wait for a later stage in the beta or for the application to be released in the App Store. 

Also, this topic is for bug reporting only. Please stay on topic. 

  • Like 1

Share this post


Link to post
Share on other sites

Version 1.5.1 iOS App

1. When I open the "add smilie" bottom left corner, and swipe left or right (because that is what most people would do), it opens the Visitors Menu or goes back to Chats. 

2. Sometimes when I scroll at a place, it goes to the last page because the app thinks I swiped left or right when I did straight.

Share this post


Link to post
Share on other sites

1zdayih.jpg

 

i just wanna report merried i think its bug from ios mobile like me and Zed were still merried but from ios i saw it were not merried, thanks hope i can help littlebit.

Share this post


Link to post
Share on other sites

And from ios also

 

i cant copy any link and the (bump) i dont hear any sound, but the person i bump they can hear the sound. Thanks!

Share this post


Link to post
Share on other sites
5 hours ago, dimplef said:

1zdayih.jpg

 

i just wanna report merried i think its bug from ios mobile like me and Zed were still merried but from ios i saw it were not merried, thanks hope i can help littlebit.

 

It's same on Android. You can't see the married/bff icon on the app actually. I think, it will be fine on the future release of the app since it's still in beta.

 

Plus, about your next post, bump doesn't work on mobile. (I think, it will be added later)

  • Like 2

Share this post


Link to post
Share on other sites

mj3klv.jpg

 

ojics0.jpg

 

Hi again, first of all please look at the difference the picture i post the transfer option from ios, this is kinda wierd of me i have many times to double check it to other users. The problem now is i have only 73xat and 24days and when i tried to click to zed acc and click transfer i saw 73xat and 17050 days. I double check this many times too even i do new update, thanks!

Share this post


Link to post
Share on other sites
4 hours ago, dimplef said:

mj3klv.jpg

 

ojics0.jpg

 

Hi again, first of all please look at the difference the picture i post the transfer option from ios, this is kinda wierd of me i have many times to double check it to other users. The problem now is i have only 73xat and 24days and when i tried to click to zed acc and click transfer i saw 73xat and 17050 days. I double check this many times too even i do new update, thanks!

Hmmm, I experienced a similar glitch. It looks like when you click "transfer", everyone has the same amount of xats. In my case, they had the same amount of xats and days. It's already on the spreadsheet. 

  • Like 1

Share this post


Link to post
Share on other sites

I have a question. 

 

If you get the option to add the "Background App Refresh", do you think it'll leave the xat opened?

It's a little bit tedious having the app opened at all times to get the messages :c.

  • Like 1

Share this post


Link to post
Share on other sites

That's what the available pawn is for, however it's been down for a while and it's being worked on. 

 

There's going to be some major fixes soon.

  • Like 2
  • Cool 1

Share this post


Link to post
Share on other sites

I have question also

 

its possible to add Trading power option from ios? 

Share this post


Link to post
Share on other sites

I am not 100% sure about this, but it seems like a good idea.

 

Might be a challenge for the admins to add in.

 

Though the app is used for mainly talking and communicating with friends and others. 

  • Like 2

Share this post


Link to post
Share on other sites
16 hours ago, dimplef said:

I have question also

 

its possible to add Trading power option from ios? 

 

eventually but don't hold your breath

anyone else seeing android crashes or BSOD ? (Black screen of death)

  • Like 1

Share this post


Link to post
Share on other sites
14 minutes ago, Admin said:

 

eventually but don't hold your breath

anyone else seeing android crashes or BSOD ? (Black screen of death)

 

Nothing, the app works fine on Android, popup messages are just broken. :) 

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Admin said:

anyone else seeing android crashes or BSOD ? (Black screen of death)

No crash and no bsod for me. (android 5.0)

Share this post


Link to post
Share on other sites
2 minutes ago, LaFleur said:

No crash and no bsod for me. (android 5.0)

Have you updated to 1.5.4 for the Android app?

 

(I haven't experienced any crashes on 1.5.4 or any BSOD).

Share this post


Link to post
Share on other sites
14 minutes ago, Maverick said:

Have you updated to 1.5.4 for the Android app?

 

(I haven't experienced any crashes on 1.5.4 or any BSOD).

Had 1.5.1, i updated it now and still no crash and no bsod.

There should be something notifying us about the new version.

 

Btw, i am getting a empty message box when i open the app now.

Share this post


Link to post
Share on other sites
11 minutes ago, LaFleur said:

Btw, i am getting a empty message box when i open the app now.

 

Yeah, it seems, admins messed up with the message box. 

 

Will be fixed on the next version.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×